Choose your certificate:


Visit this on your Apple device via Safari
in order to successfully install Zeusmos

Current Zeusmos Version: 3.3.4



If you see a 'Unable to Install' error,
you may have selected
the wrong certificate or do not have
the correct provisioning profile installed.

Do not email me about this error,
unless you have thoroughly checked that
your profiles & certificates are correct.

If you are receiving a
'Cannot Connect to alpha.zeusmos.com'
error then please try again a bit later.